Función “CONCATENAR”: problema y solución

Sandalia Cuña Sandalia Cuña Sandalia Velcros Beige Velcros Cuña Beige OkwPX8n0

La Chanclas Sandalias Zuecos De Gamuza Mujer Para Mulas Correa Corcho hdCotsrQBxconcatenación es, en general, el acto de unir o enlazar cosas.

vía Wikipedia

Recientemente un alumno de un curso de Excel me envió una duda, cuando menos, curiosa. Resulta que tenía que formar una frase: “___ ha entregado la cantidad de ___ en concepto de ___ el día ___” en relación a los datos que tenía en una tabla de excel.


En principio la solución parece simple: concatenar y pa’lante, con la siguiente fórmula:

=CONCATENAR(B2;”ha entregado la cantidad de “;C2;” en concepto de “;D2;” el día “;A2)

Pero nos encontramos con el primer problema…

Inglés · Quintana Moda El Pons Corte 8kXNO0PnwLOS FORMATOS… ¿A DÓNDE HAN IDO?

Por muy bonito que tengamos nuestros datos en la tabla, al utilizar la función de concatenado, sólo ha tomado los datos, pero no su formato, así que tenemos que decírselo antes para obtener el resultado deseado. En nuestro caso, tenemos que “convertir” nuestra fecha y dinero a texto para que al concatenar nos guarde el formato.

Nuestra solución nos la brinda otra función, poco utilizada y hasta menospreciada, pero que nos sacará las castañas del fuego cuando lo necesitemos, como ahora. Demos la bienvenida a la FUNCIÓN TEXTO.

  • Para la fecha lo haremos de la siguiente manera: =TEXTO(A2;”d/mm/aaaa”)
  • Para la cantidad lo haremos de la siguiente manera: =TEXTO(C2;”###,00 €”)
Sandalia GarvalinZapatos Sandalia Garvalín Sandalia Garvalín Infantiles Garvalín Infantiles GarvalinZapatos GarvalinZapatos Infantiles CBdxero

El formato de fecha es flexible para poder utilizarlo como queramos:

  • d/mm/aaaa
  • aaaa-mm-dd
  • d/m/aaaa h:mm a.m./p.m.etc.

Ahora tenemos que sustituir las celdas C2 y A2 en la fórmula larga anterior, por las nuevas funciones, de la siguiente manera:

=CONCATENAR(B2;”ha entregado la cantidad de “;TEXTO(C2;”###,00 €”);” en concepto de “;D2;” el día “;TEXTO(A2;”d/mm/aaaa”))Oro En Brillos Plana Con Sandalia 0OmvnwN8

De este modo, tenemos todo resuelto y visualmente resulta más agradable.

Desde la introducción de Excel 2007, para estos casos no sería necesario escribir toooooodo el tocho de fórmula, y ni siquiera sería necesario llamar a la función CONCATENAR. Podríamos haberlo hecho de la siguiente manera:

=B2&”ha entregado la cantidad de “&TEXTO(C2;”###,00 €”)&” en concepto de “&D2&” el día “&TEXTO(A2;”d/mm/aaaa”)

Marrón De Sandalias Bios Planas Inter Agmq809n7kv22a Mujer QdCtrBhxs

Bien visto, no nos ahorramos mucho (algunos bytes en el tamaño del archivo), pero bueno, ya conocemos otra forma de concatenar textos y datos a los que les podemos modificar el formato para adaptarlo a nuestras necesidades. El resultado final, visualmente, va a ser el mismo.

Sandalia Cuña Sandalia Cuña Sandalia Velcros Beige Velcros Cuña Beige OkwPX8n0

9 Comments